Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Themes /

Discuss SilverStripe Themes.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

blackcandy


Go to End


3 Posts   1579 Views

Avatar
animasola

Community Member, 121 Posts

16 May 2009 at 8:52pm

Hi,

I tried to edit the default theme of silverstripe and customize it to my desires. But what frustrates me is that, I tried editing a file, specifically the SideBar.ss but none of my changes are reflected upon the website. I tried refreshing, restarting and doing everything but nothing seems to change. I deleted the file and the sidebar still shows.

I used firefox's firebug to find the sidebar element and used grep to search within the directory for that element and it returned no results. How is the theme doing this!!?? I am getting very frustrated and do not know where the hell the theme or silverstripe is generating the sidebar since I already deleted the file.

Any piece of advice would be highly appreciated, thanks!

Avatar
Willr

Forum Moderator, 5523 Posts

17 May 2009 at 11:41am

Have you flushed the SilverStripe cache? SS generates a cached version of all the templates you can clear this by doing http://www.yoursite.com/?flush=all

Avatar
animasola

Community Member, 121 Posts

17 May 2009 at 7:24pm

thanks! worked perfectly.