Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Themes /

Discuss SilverStripe Themes.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

New Themes in webspace subdirectory installation & .htaccess ..

Go to End

5 Posts   2304 Views


Community Member, 13 Posts

20 June 2009 at 2:20am

Hi Guys,

I think this deserves its own thread ..

I have installed SS in a subdirectory at my host space / website space. I have had a successful installation and was able to use the Silverstripe install both front and backend. I then went about changing from the default theme to another by uploading the new theme ( I followed the whole proper proceedure ) and changing the "SSViewer::set_theme('xxxxxx');" line in the _config.php file under the mysite folder. Once this was done I end up now with -

It went from a perfect base install to the above and the 404 error. I went back to change the SSViewer line again to blackcandy, now it still wont work.

The act of changing the SSViewer parameter seems to have "Broken" my install. As to why it is back asking for install.php I have no idea. This was deleted as gakenny stated - you are asked to do so when the initial install is finished successfully.

And YES I flushed the installation / cleared the cache several times, didnt work!


Further update -

I reuploaded the install.php as it was asking for it, refilled in detail - site back up and running, both front and backend. I then went and changed the "SSViewer::set_theme('xxxxxxx'); " parameter in the _config.php file again to the new theme .. BANG .. back to square 1 as above.

To resurect the site I will need to reupload install.php and go through that process again. When changing the SSViewer param to anything else seems to crash the system.

Any ideas?


Community Member, 13 Posts

20 June 2009 at 2:46am

This is the content of my .htaccess at the root of install folder:

<Files *.ss>
Order deny,allow
Deny from all
Allow from

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /stripe

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]



Community Member, 400 Posts

20 June 2009 at 6:33pm

Do you get this when you try to access the only home page?

if it is so, it can be a cache problem, add ?flush=1 to the end of your URL and see,


Community Member, 13 Posts

23 June 2009 at 12:37am

Hey Nivanka,

No joy - blue in the face from doing this.

I am following Arams tutorial here:

Did what he said under the Preperation and Getting Started sections. I should - according to this tute - get a static page up at least. No go though.

I reckon most write these tutes with an install at root of ones website in mind as opposed to it being in a subfolder?

Any further ideas?



Community Member, 13 Posts

23 June 2009 at 8:08am

OK Guys,

It seems the .htaccess idea was a red herring. My host company - - looked into this further. In relation to the tutorial zipped files it seems

" .. The files in the archive had wrong permissions set. I had corrected the permissions to fix this issue. While setting permissions please use 644 for files and 755 for directories."

I must say guys - every time I ask Kionic about a problem they come through with the answer. I for one highly recommend these guys on price and service .. top notch!

Site now working -