Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Upgrading SilverStripe /

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Upgrade to 3.2 - do I need more security privileges on database server?


Go to End


6 Posts   2546 Views

Avatar
Philippe

Community Member, 6 Posts

1 November 2015 at 9:53pm

Hi,

I converted my site on my local machine to version 3.2 and also redesigned it to use bootstrap. Everything works fine.
But when I want to roll it out to one.com, I get the following error message:

[User Error] Uncaught SS_DatabaseException: Couldn't run query: SHOW DATABASES LIKE 'porschefriends_' Access denied; you need (at least one of) the SHOW DATABASES privilege(s) for this operation

And when I try to set it up from scratch using install, I get (although the database exists) the following error

"I can't create new databases and the database 'porschefriends_' doesn't exist. Please create the database manually. "

It looks like with version 3.2 I need more security privileges on the database.
Is that true?

Is there a walk around because my provider will not grant me more privileges?

Thank you in advance for any help
Philippe

Avatar
Philippe

Community Member, 6 Posts

2 November 2015 at 2:02am

Edited: 02/11/2015 2:02am

After having done some tests on my local machine it looks like the problem comes from the database and the user name.
Both ends with an underscore and SS 3.2 does not like that... (probably a bug somewhere as it worked with 3.1)

Avatar
martimiz

Forum Moderator, 1391 Posts

6 November 2015 at 4:58am

If you think this is a bug (I suppose you tried username/database with and without underscore on your local system) then please report it as an issue on GitHub:

https://github.com/silverstripe/silverstripe-framework/issues

Avatar
LoFonz

Community Member, 12 Posts

13 November 2015 at 6:16am

Has anyone been through this?

I just ran into the very same problem, but my DB name does not contain any "_"...

Any help would be appreciated :-/ (it's working correctly locally btw, so would it come from the live server??)

Avatar
Philippe

Community Member, 6 Posts

13 November 2015 at 6:56am

Edited: 13/11/2015 6:57am

Hi LoFonz - idem for me, it's working locally.
This being said, as suggested by martimiz, I created a bug issue in github
Here is the link: https://github.com/silverstripe/silverstripe-framework/issues/4765#issuecomment-155904468

Yesterday, there was a short discussion about it.
I would recommend you to add your comments to the issue in order to reinforce the need for a solution.

Avatar
LoFonz

Community Member, 12 Posts

13 November 2015 at 8:18am

Done. I guess I'll wait a couple of days and get back with SS 3.1 if it hasn't been fixed by then.

Too bad, because SS 3.2 features look really jucy :-/