Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Upgrading SilverStripe /

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Upgrading from Silverstripe 3.1 to 3.3


Go to End


3 Posts   1939 Views

Avatar
Joop53

Community Member, 9 Posts

28 February 2016 at 11:49pm

Hi I am unable to upgrade on a live database. On top off the install screen i get the message ' Warning: Invalid argument supplied for foreach() in ..../framework/dev/install/MySQLDatabaseConfigurationHelper.php on line 71'. Install complains about a non existing database. Version 3.1 worked perfect.

Avatar
camfindlay

Forum Moderator, 267 Posts

1 March 2016 at 1:30pm

You should really be testing this upgrade on a localhost development environment before upgrading live.

On another note I did write up a blog post a while back about 3.1 -> 3.2 upgrade that might come in handy: http://www.silverstripe.org/blog/leveling-up-your-silverstripe-cms-website/

Avatar
Joop53

Community Member, 9 Posts

1 March 2016 at 7:47pm

Thanks for your advice. My website is live but not public. After updating failed I have tried a clean manual install. The install program says ok on all tests but hitting install button results in the following fatal error:

Fatal error: Uncaught exception 'Exception' with message 'There are two files containing the "_database" class: "....../fam/framework/thirdparty/jstree/_demo/_inc/class._database.php" and "....../fam/framework/thirdparty/jstree/_demo/_inc/class._database_i.php"' in ...../fam/framework/core/manifest/ClassManifest.php:396 Stack trace: #0 [internal function]: SS_ClassManifest->handleFile('class._database...', '/customers/0/5/...', 5) #1 /fam/framework/filesystem/FileFinder.php(158): call_user_func(Array, 'class._database...', '/customers/0/5/...', 5) #2 ......./fam/framework/core/manifest/ClassManifest.php(311): SS_FileFinder->find('/customers/0/5/...') #3 ..../fam/framework/core/manifest/ClassManifest.php(135): SS_ClassManifest->regenerate(true) #4 ...../fam/framework/core/Core.php(100): SS_ClassManife in ...../fam/framework/core/manifest/ClassManifest.php on line 396

My provider states that the problem indicates a php error concerning :
There are two files containing the "_database" class fam/framework/thirdparty/jstree/_demo/_inc/class._database.php fam/framework/thirdparty/jstree/_demo/_inc/class._database_i.php

So i am stuck with a not completed installation