Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Upgrading SilverStripe /

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

no admin area even when upgrading to version 3

Go to End

5 Posts   1280 Views


Community Member, 49 Posts

6 July 2012 at 7:09pm


I have been able to upgrade a silverstripe installation to version 3.
I had to comment same multilanguage features in order to be able to do it and add a line that i saw in a forum in the _config.php.

The site is working ok but the admin area doesn´t loads and i just get a silverstripe logo in the middle of the screen.

By inspecting the source there should me more links to different areas on admin area.

To say the true i am starting moving same sites to worpress as it is usually very difficult to do any upgrade on silverstripe and a simple new version can place one site not operational.
The issue is that i have done same sites to same clients and i am afraid that when i upgrade them i will make their sites not operational and if i leave them as they are they can be attacked somehow.

I check the error_log and i get no errors.


Community Member, 49 Posts

6 July 2012 at 7:17pm

I tried following the advices on and the problem persists

I am able with tab to go to different links and even to see the profile page when i select this link.

I am logged but i can´t do anything to edit the pages.

That is very strange


Community Member, 49 Posts

20 July 2012 at 4:54am

I would rebuild the entire site to Wordpress.

At the moment from around 10 sites i have built with silverstripe i have already migrated 3 to Wordpress.

In same cases i have hundreds of pages of content but sametimes when an upgrade is done you cannot touch the site for a long time and that kills it.

Does anybody knows same tool to convert a silverstripe site to wordpress ?.

Sometimes Will and others give same help but is normal to stay weeks or months with no support or any idea about what is giving errors.


Community Member, 4 Posts

23 July 2012 at 8:59am


I had the same problem upgrading. I fixed it by removing assets/_combinedfiles and letting silverstripe regenerate it. I did a dev/build?flush=1 too, and removed the old jsparty folder, don't know if either of those steps are needed.



Community Member, 49 Posts

24 July 2012 at 3:16am

It didn´t work.

thank you anyway.

It is a nice tool but when is not possible to get support or when a simple upgrade destroys the site i can not recommend it.

Thank you,