Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Upgrading SilverStripe /

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Javascript Sizzle error in 3.1.0-rc1

Go to End

6 Posts   2754 Views


Community Member, 5 Posts

20 August 2013 at 6:52pm

Hi all,

I'm trying to upgrade a site to 3.1.0-rc1 and receive a Javascript Sizzle error after clicking on the "Create" button on the "Add page" CMS page.

Steps to reproduce:
1) Click "Add new" in the pages section of the CMS
2) Select "Top Level" and "Page" pagetype and click "Create"
3) This is make the add page ajax request and does lead to the following Javascript error:
Error: Syntax error, unrecognized expression:[Break On This Error]
var ret = node, expr );
4) The new pages does NOT appear. But actually it is being created and if I refresh the CMS, then the new page shows up as draft page

If I update the jQuery to 1.8.3, then the error goes away, but the CMS throws all sorts of other errors, so this seems to be no solution

The error does not occur in all SilverStripe website which I have tested. Another, more simple site, is running successfully on 3.1.0-rc1

Anybody else did see this already? Or any ideas of how this could be solved?

Thanks and best regards


Community Member, 2 Posts

4 September 2013 at 2:36pm

I got the same error here as well when i try to add a new data object in the cms.

Attached Files

Community Member, 2 Posts

4 September 2013 at 2:40pm

fixed just now, i removed the spaces between my classes the <?php tag


Community Member, 5 Posts

4 September 2013 at 8:20pm

Hi SSPenguin

thanks a lot for posting your solution. Could you please be a bit more detailed with your solution, as I have removed several spaces, but it still doesn't work.

For instance my Page.php class starts with:
class Page extends SiteTree {

private static $db = array(

Best regards


Community Member, 5 Posts

13 September 2013 at 11:01pm

Just a short follow up. For me, the problem was related to the widgets plugin. I just updated this, and now all works fine again

Best, Frank


Community Member, 5 Posts

19 November 2013 at 8:54am

Edited: 19/11/2013 12:30pm

I just came across something very similar, it is driving me nuts. Not sure what changed.

Can you be explicit with what you changed?





Left a line break above the <?php for one of my Page.php files. This was causing it not to load and therefore held up the -Pages link within the CMS.