Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Upgrading SilverStripe /

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Admin area errors after upgrade to v. 2.3.3 (from 2.3.1)

Go to End

12 Posts   3721 Views


Community Member, 5 Posts

31 August 2009 at 9:11am

You could have found more detail on the actual error by checking your Apache error log. I have realised the default error message does not help at all. If you do have access to an error log this will usually give you an idea of what may be wrong.


Community Member, 1 Post

20 September 2009 at 6:44am

I have the same error when I upgraded from 2.3.1 to 2.3.3
I solved this problem by appending ?flush=1 after /admin/



Community Member, 39 Posts

26 September 2009 at 12:58am

I got at the same stage the same error message and saw a very quick blink of a larger error message site...
after going to message site came again and showed me that I had some double files

Warning: Warning: there are two 'EditableButton' files both containing the same class: '/usr/www
/users/packag/userforms/trunk/code/editor/EditableButton.php' and '/usr/www/users/packag
/userforms/code/editor/EditableButton.php'. This might mean that the wrong code is being used.
in /usr/www/users/packag/sapphire/core/ManifestBuilder.php on line 276

I skipped the files and now it works fine.... but still I need a place to put in the files for the contact form.
Hope this helps!


Community Member, 2 Posts

7 October 2009 at 9:41am

Had the same issue after deleting a page and attempting to db/build/?flush=1. By looking at the Apache error log ("apache/logs/error.log"), i found that the MySQL temp file was locked. Stop Apache and look in the "MySQL/data" folder. Delete files listed in the Apache error log (probably look like this #sql_????_?.MYD) and restart Apache.

Go to Top