Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Widgets /

Discuss SilverStripe Widgets.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

TwitterWidgetPack - no hashtag displayed

Go to End

3 Posts   2327 Views


Community Member, 267 Posts

5 August 2010 at 12:27am


Installed the TwitterWidgetPack into the CMS. Selected Profile widget. Saved. And it works.

- When I hit the checkbox: 'display hashtag?' it doens't show the # or the word behind the hashtag.
- When I disable the checkbox, the result is the same.

- When i twitter #test, it won't display anything in the widget :( on my twitterpage it looks correct.

Any ideas?


Community Member, 267 Posts

5 August 2010 at 1:33am

Ok i got an idea of the problem:

the correct wat to display a twitter widget (according to the twitter website) is:

<script src=""></script>
new TWTR.Widget({
  version: 2,
  type: 'profile',
  rpp: 4,
  interval: 6000,
  width: 250,
  height: 300,
  theme: {
    shell: {
      background: '#333333',
      color: '#ffffff'
    tweets: {
      background: '#000000',
      color: '#ffffff',
      links: '#4aed05'
  features: {
    scrollbar: false,
    loop: false,
    live: false,
    hashtags: true,
    timestamp: true,
    avatars: false,
    behavior: 'all'}}).render().setUser('usernameHere').start();

The ouput of the SS TwitterWidgetPack is:

<script src=""></script>
new TWTR.Widget({

The php file with the code says:

function WidgetSetupJSON() {
$settings = $this->WidgetSetup();
return Convert::raw2json($settings);

- Is there a way to convert an array to version = 2, instead of "version"= 2



Community Member, 57 Posts

14 April 2011 at 4:07am

No, any text after a hashtag isn't displayed... Anyone know what's causing this?