Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Widgets /

Discuss SilverStripe Widgets.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Countdown Widget doesnt work


Go to End


3 Posts   1383 Views

Avatar
sven

Community Member, 2 Posts

17 November 2010 at 7:45pm

Hello everybody

I tried to install the countdown widget. As said in readme.txt i just copied it with ftp to the root of my silverstripe installation. Afterwards i run the command on my installation to get the wigdet working.

http://www.silverstripe.couldnt-care-less.com/dev/build

When i log in as the administrator, i can't see the widget.

Have I done anything wrong or is the countdown not yet already running on Silverstripe v2.4.3?

Avatar
Rick

Community Member, 2 Posts

26 November 2010 at 4:35am

Have you figured out what is wrong? I just tried adding the Countdown widget to a page and I get:

Fatal error: Class 'SSDatetime' not found in /var/www/wedding/docs/widgets_countdown/CountdownWidget.php on line 18

Any ideas?

Avatar
Rick

Community Member, 2 Posts

27 November 2010 at 2:03am

I see that SSDatetime has been changed to SS_Datetime. I fixed this in CountdownWidget.php and it's working fine now.