Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Widgets /

Discuss SilverStripe Widgets.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

LatestBlogPost error


Go to End


1148 Views

Avatar
lulurdz

Community Member, 3 Posts

21 July 2012 at 10:03am

Hi!
I'm new in ss, I want to have in my site the widget latestBlogPost, I download in my site, dev/build and an error appears:

[Warning] pg_query() [function.pg-query]: Query failed: ERROR: column "created" does not exist LINE 1: ...ree_Live"."ClassName" IN ('BlogEntry')) ORDER BY `Created` D... ^
GET /silverstripe/blog/

Line 187 in C:\xampp\htdocs\silverstripe\postgresql\code\PostgreSQLDatabase.php
Source

178 if(isset($_REQUEST['previewwrite']) && in_array(strtolower(substr($sql,0,strpos($sql,' '))), array('insert','update','delete','replace'))) {
179 Debug::message("Will execute: $sql");
180 return;
181 }
182
183 if(isset($_REQUEST['showqueries'])) {
184 $starttime = microtime(true);
185 }
186
187 $handle = pg_query($this->dbConn, $sql);
188
189 if(isset($_REQUEST['showqueries'])) {
190 $endtime = round(microtime(true) - $starttime,4);
191 Debug::message("\n$sql\n{$endtime}ms\n", false);
192 }
193

any clue??

thanks in advance!!