Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Widgets /

Discuss SilverStripe Widgets.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

MultiLingual Widgets in SS 3.x


Go to End


5 Posts   1803 Views

Avatar
zaucker

Community Member, 3 Posts

26 March 2013 at 4:57am

Hi,

I am wondering how to use the modules widgets and translatable together (in SS 3.x). I would like to either use different widgets or widgets with multilingual content on the different translations of the same page of a multilingual site. E.g., having a widget with various (external) links where the links on the German page would have link texts in German (and possibly link to a German document or site), the English page would have link texts in English (and link to English sites), etc.

Is this possible with widgets and translatable? If yes I'd appreciate a simple example ... and if no, anybody have a suggestion for a patch, some other solution, ...?

Thanks
Fritz

Avatar
swaiba

Forum Moderator, 1899 Posts

26 March 2013 at 8:30am

Avatar
zaucker

Community Member, 3 Posts

26 March 2013 at 9:06am

Barry,

is this known to be the solution for SilverStripe 3 as well? If it is, I must have done something wrong when I tried.

Thanks
Fritz

Avatar
swaiba

Forum Moderator, 1899 Posts

26 March 2013 at 9:27am

afaik the page and widgets basically are still the same

i adivise replying to the above thread (and on ssbits) with a meaning full description of what happened / what you noting any debug info you have and one of the ss3 folks may help you

Avatar
zaucker

Community Member, 3 Posts

26 March 2013 at 11:08pm

I tried with a fresh installation following the instructions from http://www.silverstripe.org/widgets-2/show/11375 and now it's working as expected. Sorry for the false alarm.

Fritz