Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Widgets /

Discuss SilverStripe Widgets.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Widgets Tab missing for Blog in SS3.1


Go to End
Reply


10 Posts   5173 Views

Avatar
Nachos

Community Member, 22 Posts

2 December 2014 at 6:07am

Hey there,

I finally found a weird solution and I figured I should share it with the next one having the problem. I added the code to /mysite/_config/config.yml BUT I made a fresh install in another server. That worked! Interstingly enough, following the same steps in the first server didn't help. So I deleted the files of the server, copied and pasted the files from the second one (included .htaccess, which filezilla didn't recognize) and imported the database. Not elegant at all, but it worked!

Avatar
Roguemm

Community Member, 1 Post

15 March 2017 at 9:51pm

This had me stumped too. But your responses certainly helped lead me in the right direction.

I added the following to my mysite/_config/config.yml file:

---
Name: mysite
After:
  - 'framework/*'
  - 'cms/*'
---
# YAML configuration for SilverStripe
# See http://doc.silverstripe.org/framework/en/topics/configuration
# Caution: Indentation through two spaces, not tabs
SSViewer:
  theme: 'scg'
SiteConfig:
  extensions:
    - SiteConfigExtension
BlogHolder:
  extensions:
    - WidgetPageExtension
Page:
  extensions:
    - WidgetPageExtension

I ran /dev/build?flush and the next time I entered the Admin the widget tab was available to the Blog and Page sections.

Go to Top