Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Widgets /

Discuss SilverStripe Widgets.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Widget will not install

Go to End

6 Posts   3366 Views


Community Member, 8 Posts

19 November 2009 at 10:52am

I have copied the widget folder to the root installation directory of silverstripe. In this case I copied the LoginWidget. When I go and run the dev/build script, it does nothing. I verify in the database that nothing has been created. I go and look in the CMS and it does not show my new widget in the widgets tab. Please advise.



Community Member, 37 Posts

20 November 2009 at 10:30am

Hi John,

Did you created an '_config.php' file in your widgets folder? This file can be empty except for the <?php ?> tags but what it is used for is to tell SilverStripe that this folder has files that need to be used in the CMS.

This should execute the code and add the widgets to the widget tab.

However if you have the blog module installed, you need to follow the instructions here ( if you want to use this widget on all your website pages.



Community Member, 8 Posts

20 November 2009 at 10:58am

Yes, these have the _config.php files in their directories. I downloaded the widgets from this website. I also went through the guide to enable them on all of my pages. I see the Widget tab now, but no widgets that I copied into the root directory. I ran the build also using the flush=all parameter.



Community Member, 8 Posts

21 November 2009 at 4:58am

Edited: 21/11/2009 4:59am

Could it be a file or folder permissions since these were downloaded? I do not understand why SilverStripe is not processing these. Can I do some sort of force processing? What could cause SilverStripe not to process/install a widget folder?



Community Member, 2 Posts

1 December 2009 at 5:06pm

I downloaded the LoginWidget, installed it in the Silverstripe root folder, I ran both dev/build and db/build (which method is correct now?) and logged into the CMS but I don't see a Widget tab anywhere. I've done the flush thing, I've cleared my cache and restarted the browser. I have a _config file. Am I missing a step?


Community Member, 69 Posts

7 December 2009 at 6:37am

Edited: 24/03/2013 8:41pm

i have here the same problem that widgets would not install... It looks like they are well installed (i think they are).
With drag and drop the widget i get an javascripterror (with all of them) whatever i do.

error in ie8:
Failure webpage

Uderagent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0)
Timestamp: Sun, 6 Dec 2009 17:31:11 UTC

Bericht: Deze eigenschap of methode wordt niet ondersteund door dit object (this is not accepted by this object)
Rulel: 87
Sign: 5
Code: 0
URI: http://...

what can i do about this.
Ive downloaded from the dayly build the newer WidgetAreaEditor.js, replaced the old one but got on all the pages errors... i think too much changed in the dayly build.
btw i'm using silverstripe 2.3.4.rc1