Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

SS-2015-004: TreeDropdownField and TreeMultiSelectField XSS

Severity:
Moderate (?)
Identifier:
SS-2015-004
Versions Affected:
3.1.9 and lower
Versions Fixed:
3.1.10
Release Date:
2015-02-19

A cross-site scripting vulnerability has been discovered in the TreeDropdownField and TreeMultiSelectField.

This vulnerability can only be exploited if a user with CMS access has posted malicious or unescaped HTML into any of the dataobjects used as a data source for either of these fields.

This has been resolved by ensuring that all dataobjects used as a data source have their content safely encoded.

Reported by Hugh Davenport - All The Things Ltd