Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

SS-2015-005: VirtualPage XSS

Severity:
Moderate (?)
Identifier:
SS-2015-005
Versions Affected:
3.1.9 and lower
Versions Fixed:
3.1.10
Release Date:
2015-02-19

A cross-site scripting vulnerability has been discovered in the VirtualPage class.

This vulnerability can only be exploited if a user with CMS access has posted malicious or unescaped HTML into any of the textfields of a page which a VirtualPage refers to.

This has been resolved by ensuring that VirtualPage safely escapes all field content.

Reported by Hugh Davenport - All The Things Ltd