Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

SS-2015-008: SiteTree Creation Permission Vulnerability

Severity:
Important (?)
Identifier:
SS-2015-008
Versions Affected:
3.1.0 - 3.1.10, 3.1.11-rc1, 3.0.11 and below
Versions Fixed:
3.0.12, 3.1.11
Release Date:
2015-03-19

A vulnerability exists in the permission validation for SiteTree object creation. By default user permissions are not validated by the SiteTree::canCreate method, unless overridden by user code or via the configuration system.

This vulnerability will allow users, or unauthenticated guests, to create new SiteTree objects in the database. This vulnerability is present when such users are given CMS access via other means, or if there is another mechanism (such as RestfulServer module) which allows model editing and relies on model-level permission checks.

This vulnerability is restricted to the creation of draft or live pages, and does not allow users to edit, publish, or unpublish existing pages.

All users should upgrade as soon as possible.