Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

SS-2018-015: Vulnerable dependency

Severity:
Low (?)
Identifier:
SS-2018-015
Versions Affected:
silverstripe/comments: 1.3.0, 2.0.0
Versions Fixed:
silverstripe/comments: 3.1.1
Release Date:
2018-05-28

The silverstripe/comments module, the cwp/starter-theme and the cwp/watea-theme include an outdated version of jQuery by default, which contains XSS vulnerabilities if user input is used in certain contexts. Though no known exploit has been found for these in the existing usage, user customisation to these themes could have made them exploitable.

CWP 2.0.0 has been released with the fixed cwp/stater-theme and silverstripe/comments module, and SilverStripe 4.2.0 will be released with the fixed silverstripe-themes/simple theme.

Reported by Insomnia Security.