Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

removing ImageGallery module [SOLVED]


Go to End
Reply

15 Posts   2300 Views

Avatar
KoJans

1 August 2011 at 1:31am Community Member, 14 Posts

Hi all!

I wanted to add an image gallery to my site. I have SilverStripe version 2.4.3 . Took the following steps:

  • installed DataObjectManager (build date 2011-07-28)
  • installed uploadify (modules-uploadify-r534.tar.gz)

so far everything (seemed to be) working o.k.

After that I installed ImageGallery (modules-image_gallery-r536.tar.gz). I had some issues with this module, decided to deal with them later, and tried to go back to the situation before. So I removed the image_gallery directory from the root of my SilverStripe installation, and did a /dev/build. No errors showed...
But if I go to (mysite)/admin/assets I get this error:

[User Error] Bad RecordClassName '' and $baseClass not set
GET /admin/assets/Line 2762 in /var/www/silverstripe/sapphire/core/model/DataObject.php

What did I do wrong? And more important: how can I get back my admin/assets page?

Avatar
swaiba

1 August 2011 at 2:05am Forum Moderator, 1796 Posts

Do you make any pages whilst the module was installed?

Avatar
KoJans

1 August 2011 at 2:42am Community Member, 14 Posts

Yes, I did, but I also removed them before removing the ImageGallery module.

Avatar
swaiba

1 August 2011 at 3:02am Forum Moderator, 1796 Posts

Good show, the thing with the sitetree is that the objects are versioned, so are never completely deleted... if you re-install the module does it work?

Avatar
KoJans

1 August 2011 at 3:14am Community Member, 14 Posts

O.K., I re-installed the ImageGallery module. But my admin/assets page still gives me the same error.

Avatar
swaiba

1 August 2011 at 5:29am Forum Moderator, 1796 Posts

hmmm sounds like there was something, but the ClassName has been blanked, try opening a SQL client and running this...

SELECT * FROM SiteTree WHERE ClassName = '';
SELECT * FROM SiteTree_live WHERE ClassName = '';
SELECT * FROM SiteTree_versions WHERE ClassName = '';

you might well find some records and they should not be there (i.e. delete them and then it might well work).

Avatar
KoJans

1 August 2011 at 6:01am Community Member, 14 Posts

Thanks, Swaiba!
I allready figured out it must have something to do with the database. I'll try this later.

Avatar
KoJans

1 August 2011 at 6:37am (Last edited: 1 August 2011 6:39am), Community Member, 14 Posts

The last query of the three:

SELECT * FROM SiteTree_versions WHERE ClassName = '';

gave me 11 rows. I deleted them with

DELETE FROM SiteTree_versions WHERE ClassName = '';

Then I ran /dev/build, that showed: "* Removing orphaned versioned records". So far it looked good...
But now my /admin/assets page still gives me the same error!
I also noticed that my database still has these tables: ImageGalleryAlbum, ImageGalleryItem, ImageGalleryPage, ImageGalleryPage_Live, ImageGalleryPage_versions. Would it be save to "drop" these? It scares me a little to make changes to my database outside the CMS.

Go to Top