Jump to:

4873 Posts in 7260 Topics by 1471 members

Installing SilverStripe

SilverStripe Forums » Installing SilverStripe » Double Install trouble

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 900 Views
  • Tonyair
    Avatar
    Community Member
    81 Posts

    Double Install trouble Link to this post

    Hello, guys.

    I found SS just yesterday, before that i used my own cms
    I downloaded tar.gz archive, unpacked it to my computer and installed cms w/o any troubles, but after I downloaded second one from the 2.4 branch to another directory i can't install it.

    I used same user and same password for mysql server, but only after removing first installation from the server & DB it started to work well
    (permitions of the user are unlimited)

    Linux a2nt.local 2.6.31-20-generic
    Apache/2.2.12
    PHP/5.2.10-2
    MYSQL Client API version 5.1.37

    P.S sorry for my English

  • youngmug
    Avatar
    Community Member
    19 Posts

    Re: Double Install trouble Link to this post

    As far as I know, you cannot have two installs in the same domain. If you set up a subdomain, you can run a second install on that.

  • emil.blume
    Avatar
    Community Member
    11 Posts

    Re: Double Install trouble Link to this post

    It's possible to have two installations running against one database. (e.g. showing some different Templates and modules to a customer)

    For more assitance it would be usefull to have the corrosponding logs of Apache and mySQL.

    But at all it should be easiley possible to have several different installations with different databases in different subdirs.

    I think installing silverstripe on a already used and existing database of another silverstripe installation might not work.

  • Tonyair
    Avatar
    Community Member
    81 Posts

    Re: Double Install trouble Link to this post

    Yes, i saw that e.g i didn't find where i can use surfix for db tables, so i guess it isn't possible to use one db, so i used 2 separate databases on the same server.

    Why i can't use same domain with separate dirs e.g localhost/stable & localhost/unstable?
    I mean, what is a technical reason for that?

    I didn't find any errors in apache and mysql logs, can i turn on error logging in the SS, 'cos i guess that second installation gets an empty string on some of requests and trying to parse it throw foreach construction as array which returns error.

    900 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.