Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Gallery 0.2.1

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1826 Views
  • thbeh
    Avatar
    Community Member
    6 Posts

    Gallery 0.2.1 Link to this post

    Could not get the gallery module to work. Any pointers?
    I also read through the tutorial and wondering where should I put <% include GalleryPageContent %> because i can't find the GalleryPage.ss

    Thanks

  • Willr
    Avatar
    Forum Moderator
    5502 Posts

    Re: Gallery 0.2.1 Link to this post

    GalleryPage.ss should be in the gallery/templates/layout/GalleryPage.ss or you can override this is your theme folder.

    Could not get the gallery module to work?

    First off have you rebuilt the database which should add a couple of things like GalleryPage to the database

  • thbeh
    Avatar
    Community Member
    6 Posts

    Re: Gallery 0.2.1 Link to this post

    Yes, the db have been rebuild and did not notice any errors. I could not find the path to the GalleryPage.ss file. I have checked the tar file and it is also not in there.
    Thanks

  • Willr
    Avatar
    Forum Moderator
    5502 Posts

    Re: Gallery 0.2.1 Link to this post

    ah it looks like there is no GalleryPage.ss anymore included within the module. So what you must do is make a GalleryPage.ss inside themes/your_themes/templates/Layout/ and add the <% include GalleryPageContent %> or you can add that to the themes/your_themes/templates/Layout/Page.ss file somewhere in with $Content, $Form etc.

  • thbeh
    Avatar
    Community Member
    6 Posts

    Re: Gallery 0.2.1 Link to this post

    Ok. That seems to work. Thanks a lot.

  • Balajee
    Avatar
    2 Posts

    Re: Gallery 0.2.1 Link to this post

    Hi , I am trying to get the gallery module intergrated to the silverstripe.

    I downloaded the gallery module onto the root, ran /db/build from the silverstripe url,

    I added the <% include GalleryPageContent %> themes/blackcandy/templates/Layout/Page.ss

    After refreshing the page with flush
    i dont see the galley tab , nor the cms displays and gallery page.

    What am i missing out here, any help would be greatly appreciated.

    Thanks,Balajee

    1826 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.