Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

CMS Workflow - Error on Publication Request


Reply


7 Posts   1481 Views

Avatar
rainerh

Community Member, 23 Posts

28 January 2010 at 11:23am

Hello everybody,

when I click on the Request Publication button I get a server error with the follow error description. Could somebody give me a little advice on that:

500//ERROR [Notice]: Undefined index: WorkflowComment
IN POST /admin/EditForm
Line 96 in /usr/local/src/silverstripe-v2.4.0-alpha1/cmsworkflow-v1.0-rc2/code/LeftAndMainCMSWorkflow.php

Source
======
87:       RSSFeed::linkToFeed(Director::absoluteURL('admin/cms/changes.rss'), 'All content changes');
88:    }
89:    
90:    // Request
91:    
92:    /**
93:     * Handler for the CMS button
94:     */
95:    public function cms_requestpublication($data, $form) {
* 96:       return $this->workflowAction('WorkflowPublicationRequest', 'request', $data['ID'],
$data['WorkflowComment']);
97:    }
98:    
99:    public function cms_requestdeletefromlive($data, $form) {
100:       return $this->workflowAction('WorkflowDeletionRequest', 'request', $data['ID'],
$data['WorkflowComment']);
101:    }
102:

<ul>LeftAndMainCMSWorkflow->cms_requestpublication(Array,Form,SS_HTTPRequest)

call_user_func_array(Array,Array)
line 556 of Object.php

Object->__call(cms_requestpublication,Array)

KigaMain->cms_requestpublication(Array,Form,SS_HTTPRequest)
line 292 of Form.php

Form->httpSubmission(SS_HTTPRequest)
line 135 of RequestHandler.php

RequestHandler->handleRequest(SS_HTTPRequest)
line 152 of RequestHandler.php

RequestHandler->handleRequest(SS_HTTPRequest)
line 150 of Controller.php

Controller->handleRequest(SS_HTTPRequest)
line 282 of Director.php

Director::handleRequest(SS_HTTPRequest,Session)
line 127 of Director.php

Director::direct(/admin/EditForm)
line 122 of main.php

</ul>

Avatar
Tama

Community Member, 130 Posts

27 May 2010 at 1:38pm

Edited: 27/05/2010 4:24pm

I've just come across the "Server Error" on "Publication Request" too - did you find any solution?

500 Notice: "Undefined index: WorkflowComment" at line 141 of /var/www/dev01/workflow/code/LeftAndMainCMSWorkflow.php

Avatar
Tama

Community Member, 130 Posts

27 May 2010 at 4:54pm

Edited: 27/05/2010 4:59pm

Ah ha! Looks like the directory should be named /cmsworkflow rather than /workflow.

Avatar
mark_s

Community Member, 78 Posts

27 May 2010 at 5:24pm

Hi.

Yes, you'll need to install it into the 'cmsworkflow' folder, without version numbers etc. Requirements:: calls are made that reference this directory.

@rainerh: let us know if this doesn't fix your issue.

Mark

Avatar
Tama

Community Member, 130 Posts

28 May 2010 at 8:02am

Damn, I'm now getting the error that rainerh had:

ERROR [Notice]: Undefined index: WorkflowComment
IN POST /admin/EditForm
Line 141 in /var/www/dev01/cmsworkflow/code/LeftAndMainCMSWorkflow.php

This warning is happening beforehand which may not be helping:

CMSWorkflow is not defined
[Break on this error] CMSWorkflow.setOption('noPromptForAdmin', false)

Avatar
Tama

Community Member, 130 Posts

9 June 2010 at 3:12pm

After reinstalling the module I'm no longer getting these errors.

Avatar
Roman

Community Member, 1 Post

18 April 2012 at 5:47am

Hi. I had the same problem. Renaming the installation directory from "cmsworkflow-v1.0-rc4" to "cmsworkflow" fixed it for me. Thanks!