Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Userform page type can't be activated


Reply


6 Posts   1024 Views

Avatar
wonnepfropfen

Community Member, 18 Posts

21 January 2013 at 9:45am

Hello

I have just installed the userform on silverstripe 3.0.3, but if I want to activate the page type User Defined Form, it shows me an error message.

Warning at line 670 of /home/httpd/vhosts/xyz.ch/httpdocs/silverstripe/framework/view/SSViewer.php

Would anyone know how to solve this issue?

Best,

wonnepfropfen

Avatar
Marcinkonys

Community Member, 11 Posts

21 January 2013 at 11:48am

Edited: 21/01/2013 11:49am

Some suggestions here:

  • Did you name the folder userforms?
  • Did you do a dev/build?

Quoting [url=https://github.com/silverstripe/silverstripe-userforms]UserForms@GitHub[/url]:

Installation

  • Download the module from the link above.
  • Extract the file (if you are on windows try 7-zip for extracting tar.gz files
  • Make sure the folder after being extracted is named 'userforms'
  • Place this directory in your sites root directory. This is the one with sapphire and cms in it.
  • Run in your browser - /dev/build to rebuild the database.
  • You should see a new PageType in the CMS 'User Defined Form'. This has a new 'Form' tab which has your form builder.

Also, the more info there is on the error, the easier it'll be to track what's wrong.
Go into dev mode and try accessing the page you want to edit. That will give you the complete error message.

Avatar
wonnepfropfen

Community Member, 18 Posts

22 January 2013 at 9:39am

Hi

Thank you for replying. I've installed it as stated. And it's not the first module I've installed. And I tried it now 3 times.

Unfortunately I don't get an error message with dev mode since I can't exit the page.

When I add a new page and I choose the page type "User Defined Form" I click "create" and then I get the error message. Warning at line 670 of /home/httpd/vhosts/xyz.ch/httpdocs/silverstripe/framework/view/SSViewer.php

That's it. I can see the page in my backend, but can't edit it. And I can't access the site of the frontend.

Would you have any further suggestions. Thank you!

Avatar
Marcinkonys

Community Member, 11 Posts

22 January 2013 at 10:12am

Hmm. I think when you click "Create", even without the page loading up, the URL should change.

What I do in these situations when all I'm given is that tiny popup with "Error on line X" is click on the URL in the address bar and hit Enter. That forces the page to reload. Should be given the error message then.

Avatar
IOTI

Community Member, 189 Posts

22 January 2013 at 2:22pm

Edited: 22/01/2013 2:22pm

Try doing a ?flush=all.

I just tried a fresh 3.0.3, and userforms install and got the same SSViewer error. Looking further it reported that it couldn't find a template. ?flush=all fixed it for me.

Avatar
wonnepfropfen

Community Member, 18 Posts

22 January 2013 at 9:45pm

Wow. As easy as that. ?flush=all worked for me, too.

Thank you both for your help!