Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Userforms 0.2 - Website Error?


Go to End
Reply

13 Posts   2515 Views

Avatar
dfnetchii

11 August 2009 at 6:29pm Community Member, 10 Posts

Hi Guys,

Whenever i try to install the Userforms module i can no longer access the site, and this error shows up

"Website Error
There has been an error

The website server has not been able to respond to your request."

This happens with both 0.2 and latest Trunk.

The procedure i have been following is as follows.

1. Upload "userforms-v0.2.0.tar.gz" to root silverstripe dir
2. Unzip "userforms-v0.2.0.tar.gz"
3. Rename "userforms-v0.2.0" to "userforms"
4. Run in browser http://mywebsite.com/db/build

Then i get the error.

I have also replaced Step 4 with /dev/build, /db/build?flush=1 and have also tried flushing cache from main url. No difference.

Any suggestions ?

The Silverstripe version is 2.3.3 relatively fresh install, no content added, 1 custom theme . That's all.
This is the first module ive tried installing

Cheers
df

Avatar
Hamish

11 August 2009 at 6:38pm Community Member, 712 Posts

Turn on dev mode (see: [url=http://doc.silverstripe.org/doku.php?id=debugging]debugging[/url]) to get a more useful error message.

Avatar
dfnetchii

11 August 2009 at 7:02pm Community Member, 10 Posts

Did that,

Now i get a Wall of Errors which i really can't decypher.... little help? :S

http://dev dot digitalfunk dot net/

Cheers!

Avatar
Hamish

11 August 2009 at 7:11pm (Last edited: 11 August 2009 7:13pm), Community Member, 712 Posts

Ok, your database has not been built correctly (see the message "Table 'digitalf_ecom.UserDefinedForm' doesn't exist").

Heh, you've copied something to where it shouldn't be. Check out:

http://dev dot .digitalfunk dot net/dev/build?flush=1

I think you've accidentally copied a whole lot of stuff into the google sitemaps directory. Until the build process runs successfully, the site isn't going to work. You should be able to remove the /cms/ directory from the google sitemaps directory, then try building again.

Avatar
dfnetchii

11 August 2009 at 7:23pm Community Member, 10 Posts

Wow... you were right, finger must have slipped. Thanks heaps for that.

Now for round 2... getting the module to show up in admin! yay

Avatar
Hamish

11 August 2009 at 7:24pm Community Member, 712 Posts

Kewl. Don't forget to turn dev mode off once it's in production (or even when you're not developing).

Avatar
Frank Juval

18 September 2009 at 7:38am (Last edited: 22 September 2009 12:45am), Community Member, 3 Posts

I got the same Website error. I got as far as getting it to list the errors, but now I'm stuck. Can you tell me what the next step is?

http://mysite.com/new/build?flush=1

Obviously it has to do with the DB. Not sure what thought. Everything was working fine until I uploaded the UserForms folder. That's all I did. Once uploaded, I refreshed the CMS admin page and got the Website error page.

Avatar
Willr

18 September 2009 at 3:49pm Forum Moderator, 5511 Posts

http://homeschooledhounds.com/new/build?flush=1

Should be

http://homeschooledhounds.com/new/dev/build?flush=1

To rebuild the database.

Go to Top