Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

ImageGallery - no PopUp


Reply

8 Posts   1519 Views

Avatar
Roland

27 October 2009 at 3:57am Community Member, 5 Posts

Hi,
i have installed the ImageGallery. The upload and so on works.

But PopUp's will not displayed. I have tested all PopUp styles.

I get always on site with one picture.

Thanks for any help!

Avatar
UncleCheese

27 October 2009 at 4:13am 4085 Posts

Any Javascript errors?

Avatar
Roland

27 October 2009 at 4:28am Community Member, 5 Posts

Hi Uncle Cheese,
no there are no Javascript Error.

On the site Files & Pictures (in german Dateien & Bilder) i get this Error in the statusline:

Details zum Fehler auf der Webseite:
Meldung: Das Objekt unterstützt diese Eigenschaft oder Methode nicht.
Zeile: 39
Zeichen: 1
Code: 0
URI: http://www.website-preview.de/assets/cmsmain.js?m=1256277158

Is this a hint?

Thanks!

Avatar
UncleCheese

27 October 2009 at 6:20am 4085 Posts

I'm not sure what would cause that. Have you checked if all the javascript files are brought into your source code? For instance, if you've selected FancyBox as your popup, there should be a fancybox.js and fancybox.css somewhere in your source code on the ImageGallery page.

Avatar
Roland

29 October 2009 at 7:58pm Community Member, 5 Posts

Hi,

i don't find the failure. I have reinstalled Silverstripe - it works!!!

Avatar
UncleCheese

30 October 2009 at 2:08am 4085 Posts

Haha. You're welcome!

Avatar
adefaveri

11 June 2010 at 3:28am Community Member, 1 Post

Hi!
We have the same problem, but also two javascript errors:

$.support is undefined
[Break on this error] isIE6 = !$.support.opacity && !window.XMLHttpRequest,
jquery...9282770 (riga 29)

$("a.fancybox").fancybox is not a function
[Break on this error] 'overlayShow': true

(copy&paste from firebug)

We use Silverstripe 2.3.7.
Thanks in advance!

Avatar
UncleCheese

11 June 2010 at 4:00am 4085 Posts

If you're running 2.3, you need to use the 2.3 branch. See the sticky in the DOM forum.