Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

SS 2.2.0rc1- OpenID


Reply

5 Posts   1342 Views

Avatar
dio5

14 November 2007 at 11:09pm Community Member, 501 Posts

Hi,

I'm trying to log in with my openid from myopenid but I just can't get in.

I've added the openID url to the member in Security, but everytime I want to login
I get :

"Either your account is not enabled for OpenID/i-name authentication or the entered identifier is wrong. Please try again."

I must be overlooking something stupid here. Do I have to add something somewhere? Or enable something in openID? I've tried with three different openid-urls...

Or could the problem be the fact that I'm doing it on localhost?

Avatar
Sigurd

16 November 2007 at 5:38pm Forum Moderator, 628 Posts

What's your OpenID? If your openid server is delegated, then it wouldn't have worked yet; a fix is in 220rc2 that will come out next week.

Avatar
dio5

16 November 2007 at 10:43pm Community Member, 501 Posts

Just a normal openid, nothing delegated.

But I've heard there was something not working, so I'll check again for a new version on svn in some days.

Avatar
Sigurd

19 November 2007 at 11:46am Forum Moderator, 628 Posts

The item that wasn't working was delegated openid. Check out the rc2 that is being built shortly; sign up to our silverstripe annoucements list to be emailed when it comes out;

http://groups.google.com/group/silverstripe-announce/

Avatar
sonicparke

28 November 2007 at 8:41pm 74 Posts

This hasn't worked for me at all when using a delegated openid. I've upgraded to the full version of 2.2.0 and I'm still getting the same error.

"Either your account is not enabled for OpenID/i-name authentication or the entered identifier is wrong."

However, when I use "openid.aol.com/screenname" it works fine. Anybody have any thoughts on this?