Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

out of memory error


Reply


2 Posts   3649 Views

Avatar
ivanoats

Community Member, 1 Post

26 April 2007 at 6:08pm

Fatal error: Out of memory (allocated 524288) (tried to allocate -1 bytes) in /Library/WebServer/Documents/silverstripe/install.php on line 302

I'm just trying to install the software and try it out.

here's the first part of my phpinfo();

System   Darwin athena.local 8.9.1 Darwin Kernel Version 8.9.1: Thu Feb 22 20:55:00 PST 2007; root:xnu-792.18.15~1/RELEASE_I386 i386
Build Date   Apr 20 2007 11:13:14
Configure Command    './configure' '--with-xml' '--with-zlib' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr/local' '--with-mysql=/usr/local/mysql' '--with-apxs=/usr/sbin/apxs'
Server API   Apache
Virtual Directory Support   disabled
Configuration File (php.ini) Path   /usr/local/lib/php.ini
PHP API   20041225
PHP Extension   20060613
Zend Extension   220060519
Debug Build   no
Thread Safety   disabled
Zend Memory Manager   enabled
IPv6 Support   enabled
Registered PHP Streams   php, file, data, http, ftp, compress.zlib
Registered Stream Socket Transports   tcp, udp, unix, udg
Registered Stream Filters   string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, convert.iconv.*, zlib.*

Avatar
Sigurd

Forum Moderator, 628 Posts

26 April 2007 at 9:35pm

How much memory have you permitted PHP to use?

Seems you need to raise this limit. We suggest 32MB.