Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Trouble uploading big images


Reply


8 Posts   1478 Views

Avatar
joelg

Community Member, 129 Posts

6 November 2008 at 3:26am

Hi everybody

I'm having some trouble uploading big images. Everytime I upload an image over 1-2 mb, the individual site becomes blank.

I can see other pages, but the subpage with the large image goes blank. In the CMS the picture field just doesn't show a picture.

Can anyone help me out?

See php info here: www.gulvsalg.com/info.php

Avatar
joelg

Community Member, 129 Posts

10 November 2008 at 11:17pm

No one?

Avatar
Liam

Community Member, 470 Posts

11 November 2008 at 5:48am

I would guess it has something to do with the php memory limit as you're only running 24M right now.

Create a file php.ini in your root directory of SS (or root directory) and add this line

memory_limit = 32M (or 64M)

Avatar
joelg

Community Member, 129 Posts

11 November 2008 at 11:27pm

Hi LeeUmm

Thanx for your help. I did what you said, but I'm still having some troubles.

I tried to upload a 3,6 mb image in the Files & Images tab in SS, but when I press the "edit asset" button just to view the image, the "View/Edit Asset"-window just turns blank. And the same thing happends if I insert a large image into a page, the page turns blank...

Any ideas?

Avatar
Liam

Community Member, 470 Posts

12 November 2008 at 6:42am

It probably is a memory issue as that is a pretty large file to insert. On the blank page, when you view the source of it, does it have any output/errors/warnings?

Avatar
joelg

Community Member, 129 Posts

12 November 2008 at 11:16pm

No, no error or warnings in the source code. Have a look at the page here:

http://www.gulvsalg.com/test/

I know it's a large file, but my clients haven't always got time or knowledge to check file sizes and resize images before they upload to the site. So I would really like some sort of solution to the problem...

Avatar
juandavidgc

Community Member, 36 Posts

12 November 2008 at 11:31pm

Hi!!!

I have a similar problem. I have to upload files, between 5-15MB. When i try to upload the file, i got that error:

Notice: Undefined variable : status in public_html/cms/code/AssetAdmin.php on line 221

and the uploading stops. Anyone knows a solution?

Avatar
Liam

Community Member, 470 Posts

13 November 2008 at 5:29am

Noticed your phpinfo() is still showing 24m. Maybe the increase didn't work. You're running in cgi mode, so that is the correct way to do it.

Could try putting site in dev mode to see any errors, but doubt it will show anything. in config add Director::set_environment_type('dev');

Can also look through your php error logs for anything.