Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Silverstipe won't accept database with "." in the name - any way round this?


Reply

2 Posts   1325 Views

Avatar
Lippy

1 December 2008 at 8:20am (Last edited: 1 December 2008 8:21am), Community Member, 1 Post

All my current databases have the prefix "domain_._" but trying to enter this in the installation form and the fullstop just gets stripped out and so it cannot connect to the database.

I could remove the fullstop form my domains settings, but that would mean renaming all the other databases (and associated programmes) currently using this domain which is far from ideal.

Is there a workaround for this?

Avatar
Willr

1 December 2008 at 12:40pm Forum Moderator, 5511 Posts

You could try just try installing it then overriding the database name in the config file. I don't know why the installer strips . So what you can try is to manually install SS. All the installer does is check install requirements then create the mysite/_config.php file and the .htaccess file. You can do this yourself. If you have installed SS before / on a local webserver just upload the .htaccess file from that to the root folder of your silverstripe installation. Then copy the mysite/_config.php file of your installed version to new site and edit this file with your correct database details