Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Flickr Image Gallery for SilverStripe

Go to End

33 Posts   20165 Views


8 Posts

21 July 2007 at 7:08am

Havnig a problem with this...

In my controller:

	function FlickrPhotos($limit =10){
	//getting my nsid
	$flickr = new FlickrService();
	$me = $flickr->User('ucabwm');
	$photos = $flickr->getPhotos("", $me, 5);
	//$photos = $flickr->getPhotoSet('72157594330625954','phobo', $limit);
	return $photos;

and in my page:

		<% control FlickrPhotos %>
			<a href="$page_url"><img src="$image_url"/></a>
		<% end_control %>

And I'm getting: Error

The website server has not been able to respond to your request.


Google Summer of Code Hacker, 76 Posts

21 July 2007 at 1:10pm

Edited: 21/07/2007 1:37pm

Do you get this every time you reload the page or is this error is random ?

Main reason for this is flickr service experiencing downtime, but there may be other issues such as typography errors may also be the cause for this.

TMCW, if you are using mashups 0.1.1 the code you are currently using is revised a bit, see for updated code.


8 Posts

21 July 2007 at 1:59pm

My posts are still getting eaten by the Forum. Don't get me wrong, I like the look of it, but bugs that eat content are not friendly.

Anyway... I get the error every time I load the page. Is there a debug mode so that I can get more information than this 500-style 'critical error' message?


Google Summer of Code Hacker, 76 Posts

21 July 2007 at 2:13pm

TMCW : What is the version of mashups module you are running ?
Make sure you have the latest version 0.1.1
Also, try updating the code as per

BTW, does creating a flickrGallery page also throws the same error ?


8 Posts

21 July 2007 at 3:15pm

(By the way, I've needed to modify the forum urls to reply to this post. Something's really messed up)

And, yeah, I'm using the latest version and FlickrGallery does not return any errors.

Code is..

      <% control FlickrPhotos.PhotoItems %>
	<a href="$page_url"><img src="{$image_path}_s.jpg"/></a>
      <% end_control %>


	function FlickrPhotos()
		$flickr = new FlickrService();
		$photos = $flickr->getPhotos("", "ucabwm", 5);
		return $photos;

in HomePage_Controller. No dice.


Community Member, 1 Post

26 January 2008 at 11:27am


I woud really appreciate some help here.

I love SilverStripe, I love the Flickr Plugin even more.

1) rite now what I need is Next / Back, just like the lightwindow gallery, when the images are zoomed for flickr gallery (this is super important). I read and i tried some solution you gave, but seems like this gallery code has changed, and i dont find any file. URGENT PLEASE

2) Suggestion for the new FlickrGarller:
- creating a page which will automatically pick up all the tags from your flickr accound, and display them on the page. so when a user clicks any tag from that, those pics from flickr are shown, just like your current flickr pics yby tags. only difference is the user gets to pick / click the tag of his choice..from your flickr ID tags list.

3) Suggestion:
- size of the thumbnail option in each of your template, so some flickr page i can have a bigger thumbnail, or as big as the page itself and choose to have a single pic displayed per i dont need the users to click on the pic for bigger views, only if they need a full scale view they can click.

IF you can do these 2 things for your new flickr updated module, WOW this would be awesome

Thank you very much


Community Member, 2 Posts

6 October 2008 at 6:37am

Hey guys,

I've got a problem with my flickrGallery:
I don't know why but everytime someone hits the flickr-part of my page, there is only this message:

Fatal error: Call to undefined function curl_init() in /(...)/sapphire/api/RestfulService.php on line 83

I double-checked the config.php-file, resetted the flickr-parts of the db twice and uninstalled&reinstalled the whole modul. Also got 2 new API-Number from flickr.
But nothing changed :(

D'ya got any idea why? Other modules are working very well...


Community Member, 473 Posts

6 October 2008 at 8:49am

It sounds like you don't have curl enabled.

If you do a phpinfo(); does curl appear on it?