Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

E-Commerce Modules /

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

Some Questions about the eCommerce Module


Reply


6 Posts   635 Views

Avatar
neilcreagh

Community Member, 94 Posts

11 January 2012 at 12:52am

Hi, The documentation for the eCommerce Module is really lacking, and navigating the forums for information results in a lot of mixed messages between old and new versions. I'm new to the eCommerce Module so I have a few questions I wonder if anyone could help me with:

I'm using the latest release v0.8.1

1. Do I need to create a new folder for my theme or not? eg. myThemeName_ecommerce? Some of the images don't show up in Safari (Like the + and - images to change quantity) it looks like it's looking for my theme folder with _ecommerce after it - but in Firefox these images appear?!

2. The admin email is not being sent (or at least I'm not getting it). It looks like the email to the customer is going out but not copied to the admin. I have Email::setAdminEmail('neil@fuel.ie'); in my main config file but this hasn't done the trick - is there anything else I need to do?

3. I'm using 'Cheque' payment (so customers can make an order without payment) and also a Paypal Express Checkout option. When I try to make an order using the 'cheque' option the next screen either says:
"You can not checkout this order because you are not logged in. To do so, please login first, otherwise you can checkout your current order."

or if I'm logged in as a customer it says:
"You do not have any order corresponding to that ID, so you can't checkout this order."
The confirmation order email to the customer still gets sent though, so this appears to be working - I'm just wondering if I've left something out or am doing something wrong?

Any assistance would be really appreciated, thanks.

Avatar
neilcreagh

Community Member, 94 Posts

12 January 2012 at 7:10am

Bump. Anyone got any tips on this?

Avatar
tazzydemon

Community Member, 122 Posts

13 March 2012 at 12:24pm

Edited: 13/03/2012 12:25pm

I think I might.

I modified the Order class to try to fix this as bcc did not seem to go out. As a result I was able to customise the admin header. However I think the real culprit was in my _config.php where I had set:

Email::send_all_emails_to('me@somewhere.com');

This seems to hijack everything.

My mod anyway Order.php L876:

      $email = new $emailClass();
      $email->setFrom($from);
      $email->setTo($to);
      $email->setSubject($subject);
      $email->populateTemplate(
         array(
            'PurchaseCompleteMessage' => $purchaseCompleteMessage,
            'Order' => $this
         )
      );
      $email->send();

$adminemail = new $emailClass();
      $adminemail->setFrom($from);
      $adminemail->setTo(Email::getAdminEmail());
      $adminemail->setSubject("Order on the Website");
      $adminemail->populateTemplate(
         array(
            'PurchaseCompleteMessage' => $purchaseCompleteMessage,
            'Order' => $this
         )
      );
$adminemail->send();

Avatar
Jedateach

Forum Moderator, 227 Posts

14 March 2012 at 1:16pm

Hi neilcreagh,

I'm aware of the theme issue with the + and - images not showing. In the latest version, I've just removed these images.

The module assumes you've set the admin email using Email::setAdminEmail([youraddresshere]) , I could change this if it's not flexible enough.

Are you still having issues? I've subscribed to this forum topic, so I should get your reply.

Jeremy

Avatar
neilcreagh

Community Member, 94 Posts

14 March 2012 at 11:25pm

Hi Jazzydemon & Jedateach, thanks for your replies.
I got over most of the issues by hacking the module core files (I know it's not the best practice) manually adding or remove items. eg. Pointing to my image files, manually adding the email address to send to, and removing the error message that displays for users paying by cheque. It's not the best solution but it works for this site.

Jeremy is there plans to update the module to work with 3.0?

Avatar
Jedateach

Forum Moderator, 227 Posts

15 March 2012 at 10:17am

Yes, I do plan on updating the module to work with 3.0.

If you have issues in future, I encourage you to post them here, as individual issues:
https://github.com/burnbright/silverstripe-shop/issues

Also be aware that I've forked the ecommerce module, and called my version 'shop': http://ss-shop.org/