Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

generating a CSS page, possible bug? 404 error Link to this post


Reply


3 Posts   724 Views

Avatar
vancouverWill

Community Member, 121 Posts

5 March 2010 at 4:17pm

Edited: 05/03/2010 4:17pm

I posted in template forum originaly but didn't get any response so thought maybe I should try. Hopefuly this helps someone or gives a possible idea to developers.

Hi

I tried to use

Director::addRules(80, array(
   'sitesettingsmodule/sitesettings.css' => 'SiteSettingsCSS',
));


in _config.php but received a 404 page not found error.

I was doing this to create a css page so that I can have a dynamic CSS page which I can control from the CMS. For example being able to change the background color from within the CMS.

i have used this method before to create XML pages, no tag pages, php pages and all to no problem. I had a look in the back end and couldn't see any where this was blocked. Anyone had any experience with this? it seens like it could be a bug, I don't see any security reasons as to why Silverstripe would block it but perhaps they didn't think to include it either.

Thanks very much for your help.

Avatar
vancouverWill

Community Member, 121 Posts

23 March 2010 at 10:42am

have I put this in the wrong place? Is this a bug?

Avatar
vancouverWill

Community Member, 121 Posts

24 March 2010 at 6:37am

no ideas anyone? if this isn't built in functionality it really should be.