Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

starting a new project. 2.4 or 2.3??


Reply


2 Posts   849 Views

Avatar
DsX

Community Member, 178 Posts

8 April 2010 at 4:52am

I am about to start my first 'big' project with silverstripe.
I require the ecom mod as well as a few others and a minimum of 2 levels of frontend webuser access. (retail and wholesale).
I would very much like to take advantage of the new features in 2.4 but and very concerned that the available modules will not be compatible within the next while.

What do the more experienced developers recommend?

I am thinking its probably best to develop in 2.3 and keep an eye on the status of my required mods, and consider to do the upgrade before launch if it looks feasible?

Or are the SVN of most major mods (including ecom) ready for 2.4?? I don't know since the module section of the site doesn't list many updates.

Avatar
Pigeon

Community Member, 243 Posts

8 April 2010 at 5:52am

I'm about to start a big project and have decided to go for 2.4 as 2.3 is already starting to be depreciated by module developers and it will increase the longevity of the site from a maintenance point of view.

However, have you used the ecommerce module before? I dont think it is 2.4 compatible for a start (but they might have added a patch somewhere) AND it the beta (which is what i used for a project) is not complete. Be careful, unless you have done it before.