Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Security Logout Problem


Reply


3 Posts   1012 Views

Avatar
SSadmin

Community Member, 90 Posts

15 June 2010 at 12:22pm

Hey,guys, i met a logout problem in silverstripe 2.4 these days.
If the website is viewing in both front and backend, and did some operations on backend eg.(change and save and publish), a pop up window says please logout and try again...but i am the admin and have the highest permission..:(
anyone have any ideas?

Running firebug it shows the error:
http://mydomain/admin/getitem?ID=111&ajax=1 403 Foridden

not too sure what kind problem is that?!
cookies or session ? or something else?!

Avatar
Willr

Forum Moderator, 5513 Posts

15 June 2010 at 4:37pm

Have you been logged in for a while? I believe logged in sessions only last for a limited amount of time so its possible that after a period of being logged in your session has expired.

Avatar
SSadmin

Community Member, 90 Posts

15 June 2010 at 5:22pm

Hey.Willr, thanks for replying.
i have been logged in for a while, but as long as i click and refresh some frontend page, then go back to admin area(backend), select page in left hand site-tree view, it shows the strange problem.
Have tested some other site i have built in 2.4, but only this one seems little bit odds.

i tried to comment out the permission check code in the Leftandmain.php for admin/getitem?ID=111&ajax=1
   //   if($record && !$record->canView()) return Security::permissionFailure($this);
Seems the problem still remaining.

Any thoughts on that?!

cheers.
Alex