Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Critical Help!


Reply

11 Posts   684 Views

Avatar
airgrace

25 October 2011 at 6:13am Community Member, 8 Posts

I believe your mentioning the one that's found in the root of public_html. This all I see.

### SILVERSTRIPE START ###
<Files *.ss>
   Order deny,allow
   Deny from all
   Allow from 127.0.0.1
</Files>

<Files web.config>
   Order deny,allow
   Deny from all
</Files>

ErrorDocument 404 /assets/error-404.html
ErrorDocument 500 /assets/error-500.html

<IfModule mod_alias.c>
   RedirectMatch 403 /silverstripe-cache(/|$)
</IfModule>

<IfModule mod_rewrite.c>
   SetEnv HTTP_MOD_REWRITE On
   RewriteEngine On

   RewriteCond %{REQUEST_URI} ^(.*)$
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
</IfModule>
### SILVERSTRIPE END ###

Avatar
swaiba

25 October 2011 at 6:27am Forum Moderator, 1796 Posts

ok that looks fine... so I am back to thinking it is the database connection from the enviorment files...
if it was me I would download the entire site and search for the dbname and search unix for all of the env config files used

The only reason that data appears in different site must be becasue it shares the database - however you do it that is what you are looking to prove/disprove right now.

Avatar
airgrace

25 October 2011 at 6:30am Community Member, 8 Posts

Yeah, I have a feeling that is what is happening, that the database is being accessed. I'll download the entire sites, and search for the dbnames.