Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

SS3 + Safari and missing (tinyMCE) HTMLEditors in CMS


Reply


6 Posts   875 Views

Avatar
vwd

Community Member, 160 Posts

29 August 2012 at 9:19pm

Hi,

Just wondering if anyone else is having issues with missing HTML Editors (TinyMCE) in the CMS when using Safari (6.0 on OSX 10.7.4). All HTMLEditor fields are missing.

I keep getting this error in the Javascript error console:

ReferenceError: Can't find variable: tinyMCE

No issues noticeable in other browsers e.g. Chrome & FireFox.

Thank you.
VWD.

Avatar
vwd

Community Member, 160 Posts

30 August 2012 at 2:57am

Just tested it on Safari in old iOS device (3.1.3) and it's having the same issue. So I'm assuming it's isolated to Safari?

Anyone else come across this issue?

Thanks.
VWD.

Avatar
vodoomoth

Community Member, 22 Posts

1 September 2012 at 5:06am

No, not me. I don't use Safari and I don't have an iOS-powered device.

I'm answering just so you don't feel as lonely on your thread as I do on those that are mine.
Cheers.

Avatar
simon_w

Forum Moderator, 474 Posts

1 September 2012 at 12:02pm

This was related to a bug in the index.php fall-back if the rewrite rules can't be used. A fix is provided [url=http://www.silverstripe.org/installing-silverstripe/show/20012?start=8]here[/url] or (if you're using Apache) make sure mod_rewrite's enabled and AllowOverride is set to All for the folder with your installation in it.

Avatar
vwd

Community Member, 160 Posts

4 September 2012 at 5:06am

@vodoomoth - thanks for your post! Now I don't feel so lonely!

Avatar
vwd

Community Member, 160 Posts

4 September 2012 at 5:15am

@simon_w - Thank you for your reply Simon. I can confirm that the server does have mod_rewrite enabled.

Actually, it turned out to be a strange problem in the end. It turned out to be a corrupt _combinedfiles/cmsmain.js that kept getting copied over the properly generated/combined cmsmain.js file.

Thanks very much for taking your time to respond, Simon.

VWD.