Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Composer update results in "Could not scan for classes inside framework//tests/behat/features/bootstrap"


Go to End
Reply

11 Posts   1167 Views

Avatar
Tama

16 June 2014 at 2:51pm (Last edited: 16 June 2014 2:51pm), Community Member, 130 Posts

Running "composer update" on a Silverstripe SS3.1 installation in Windows 8 returns the following:

C:\wamp\www\example>composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Writing lock file
Generating autoload files

[RuntimeException]
Could not scan for classes inside "framework//tests/behat/features/bootstra
p" which does not appear to be a file nor a folder

update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock]
[--no-plugins] [--no-custom-installers] [--no-scripts] [--no-progress] [--with-
dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [packages1] ... [
packagesN]

Does anyone know what I can do to fix this?

Avatar
Tama

18 June 2014 at 8:09am Community Member, 130 Posts

Any ideas would be appreciated.

Avatar
camfindlay

18 June 2014 at 12:11pm Forum Moderator, 149 Posts

Hey Tama,

Can you post your composer.json file? I have heard composer being a bit of a pain at times on windows, perhaps try clearing the composer cache?

Avatar
Tama

19 June 2014 at 10:06am Community Member, 130 Posts

Hi Cam, thank you for the reply.

I just tried clearing the cache and still got the "Could not scan for classes inside" error message.

Here is my composer.json file for this project:

{
   "name": "silverstripe/installer",
   "description": "The SilverStripe Framework Installer",
   "require": {
      "php": ">=5.3.2",
      "silverstripe/cms": "3.1.0",
      "silverstripe/framework": "3.1.0",
      "swipestripe/swipestripe": "2.1.*@dev",
      "frankmullenger/payment-cheque": "dev-master",
      "swipestripe/swipestripe-addresses": "2.1.*@dev",
      "swipestripe/swipestripe-category": "2.1.*@dev",
      "swipestripe/swipestripe-flatfeeshipping": "2.1.*@dev",
      "swipestripe/swipestripe-flatfeetax": "dev-master",
      "swipestripe/swipestripe-currency": "2.1.*@dev",
      "swipestripe/swipestripe-docs": "dev-master",
      "rywa/silverstripe-foundation-forms": "dev-master"
   },
   "config": {
      "process-timeout": 600   
   },
   "minimum-stability": "dev"
}

Avatar
camfindlay

19 June 2014 at 1:29pm Forum Moderator, 149 Posts

Tama, I'm just running your composer file here - I'll report back if I find something out.

Can you give me more details about your local dev environment? and is composer working in other projects ok?

Avatar
Tama

19 June 2014 at 1:41pm Community Member, 130 Posts

Thanks Cam.

I'm running WAMP on Windows 8, all my dev projects are sitting in c:\wamp\www\

I've just run "composer update" on two other projects (that don't include Swipestripe) and they're working fine.

Avatar
camfindlay

19 June 2014 at 2:13pm Forum Moderator, 149 Posts

Just ran it on OSX native PHP - composer completes as expected, might be a windows specific issue.

I have a win7 VM I might try on that.

Are you using git bash or something like that to run the composer commands?

Avatar
Tama

19 June 2014 at 2:16pm Community Member, 130 Posts

I appreciate you looking in to this Cam, thank you.

I've been running composer in standard Windows command line.

Just tried Git Bash and got the same message, damnit.

Go to Top