Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

installing silverstripe on WAMP I get the You need mod_rewrite to run SilverStripe CMS, but it is not enabled. Error.


Reply

4 Posts   1853 Views

Avatar
TF-35Lightning

18 February 2010 at 6:48pm (Last edited: 18 February 2010 6:49pm), Community Member, 137 Posts

Hi all,
First time installation of silverstripe here. I'm on Vista, and have installed a working version of WAMP.

On the install under:

Webserver Configuration
mod_rewrite enabled   You need mod_rewrite to run SilverStripe CMS, but it is not enabled.

This line is highlighted in red. I have read of other user posts and have tried those solutions but I still get the error, I see it is related to the .htaccess and httpd.conf

Here is what I have for those files.

.htaccess
### SILVERSTRIPE START ###
<Files *.ss>
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Files>

<IfModule mod_rewrite.c>
RewriteEngine On

RewriteCond %{REQUEST_URI} !(\.gif$)|(\.jpg$)|(\.png$)|(\.css$)|(\.js$)

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
</IfModule>
### SILVERSTRIPE END ###

httpd.conf
LoadModule rewrite_module modules/mod_rewrite.so

If anyone could help me out here would be much appreciated! Desperate to get silverstipe up and going.

Avatar
Sean

18 February 2010 at 11:06pm Forum Moderator, 921 Posts

Easily fixed by enabling the "rewrite module" in the Apache modules listing inside the WAMP menu in your task bar.

Avatar
TF-35Lightning

19 February 2010 at 12:07am Community Member, 137 Posts

Well that was an easy fix thanks Sean! First time using WAMP and I really don't know how I didn't cross over sooner from the Microsoft platform!

Another question regarding Silverstripe its awesome, just having a small difficulty with the file uploading component at the moment. I go to files and images and upload the files I want eg (.jpg and pdf) now they show up there listed on that page, but back on the Site Content area when I go to insert a .jpg the file I just uploaded isn't showing up???

I go to insert image, select the upload directory but the image I just uploaded isn't showing from the selection list. Any ideas?

Avatar
Sean

23 February 2010 at 11:08pm Forum Moderator, 921 Posts

Hi there,

You might want to open a new thread in the General Questions forum so someone else can take a look. I'm not sure off the top of my head, sorry!

Cheers,
Sean