Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

IIS 7.5 - MySQL - SS 3.0.5 - Error on Page Save/Publish


Reply


2 Posts   423 Views

Avatar
Jogi

Community Member, 3 Posts

9 April 2013 at 1:17pm

Good evening members,

I'm already working for 5 hours to get SS3 running on my Windows 2008 Server with IIS 7.5 - but still not getting on with it :-(
After fixing some minor issues (removed "/" from the web.config and properly configuring the server) I was luckily able to finish the installation and log on to the admin interface.

Everything seemed fine until I started editing the pages. The problem is: It doesn't matter which page type im editing I'm not able to save and publish the page. It always takes several seconds until a dark message box in the top right corner appears displaying:
"Error at line 580 of framework\model\MySQLDatabase.php"

I already successfully setup the system on a WAMP Server but can't get this running on the IIS -
has anyone any idea how finally get this working or what the error means?

Greets
Jogi

Avatar
Jogi

Community Member, 3 Posts

9 April 2013 at 1:27pm

I already figured out, that this probably has to do with the versioning system -
because the changes are saved and the new page published even the error gets displayed....