Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

won't install - change content of htaccess


Reply


5 Posts   1970 Views

Avatar
Audster

Community Member, 6 Posts

3 August 2009 at 10:07pm

Having trouble with install, I think I know why but don't know how to fix - would much appreciate if anyone knows.

Have done the change ownsership of htaccess and it's at 777.

I think I have to change something in htaccess.

My host provider says:
Our servers use Apache's standard mod_rewrite, enabling you to create applications that are user friendly, search engine ready and help to reduce malicious access to the inner workings of your code.

Example code:
RewriteEngine on
RewriteOptions inherit
RewriteBase /bin-cgi/
RewriteRule ^.cgi$ - [T=application/x-httpd-cgi]

Avatar
Hamish

Community Member, 712 Posts

6 August 2009 at 12:35pm

...what is the error?

Avatar
Audster

Community Member, 6 Posts

18 August 2009 at 2:34am

sorry for late reply,

I know that mod_rewrite is enabled on the server (shared hosting)

At the install screen, I get these two errors:

1
Is the .htaccess file writeable?   User 'domain2301642' needs to be able to write to this file:
/home/fhlinux132/s/silverstripe.myupdater.co.uk/user/htdocs/.htaccess

The file is currently owned by 'root'. There is no user-group that contains both the web-server user and the owner of this file. Change the ownership of the file, create a new group, or temporarily make the file writeable by everyone during the install process.

2
Webserver Configuration

Server software   I can't tell what webserver you are running. Without Apache I can't tell if mod_rewrite is enabled.
mod_rewrite enabled   I can't tell whether mod_rewrite is running. You may need to configure a rewriting rule yourself.

Avatar
Hamish

Community Member, 712 Posts

18 August 2009 at 9:32am

have you tried changing the ownership of the file, creating a new group, or temporarily making the file writeable by everyone during the install process?

Avatar
Audster

Community Member, 6 Posts

18 August 2009 at 8:31pm

I have changed ownership and made it writeable by all (it's at 777)