Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

SS-2015-026: Form field validation message XSS vulnerability

Severity:
Important (?)
Identifier:
ss-2015-026
Versions Affected:
3.1.15 and below, 3.2.0
Versions Fixed:
3.1.16, 3.2.1
Release Date:
2015-11-16

A high level XSS risk has been identified in the encoding of validation messages in certain FormField classes.

Certain fields such as the NumericField and DropdownField have been identified, but any form field which presents any invalid content as a part of its validation response will be at risk.

Common Vulnerability Scoring System (CVSS) Information

Credit to "Arjun Basnet from Cyber Security Works Pvt.Ltd (http://cybersecurityworks.com/)"