Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Errors installing RC3 - Linux, Apache


Reply

13 Posts   4395 Views

Avatar
fishe

10 March 2009 at 8:00am Community Member, 42 Posts

You're likely not able to access a custom php.ini file. But ask your host if there is any solution here - who knows what their set up is.

Other people will have to help here, but I believe you can put some PHP directives in the .htaccess file, possibly? But this probably won't help as if it is a similiar issue to mine it'll be a problem with the server's php.ini file having a faulty character or something like that.

It's a real nasty issue huh. Just another one of those things when you're dealing with many interconnected open source products :)

You're best bet might be to copy/paste them my solution and frame it like: It's highly likely there is a problem with your PHP configuration, could you please check to make sure there are no extra tabs/spaces or other issue with the register_argc_argv statement.

Avatar
Yulia

10 March 2009 at 8:13am (Last edited: 10 March 2009 8:17am), Community Member, 26 Posts

thank you for a quick reply,

after doing some research, i decided to create php.ini file with the code you posted.
like so:

register_argc_argv = on;

I think somehow it worked and overwritten the one on a server. The error is gone now.

btw... this is exactly what i told them to check. Instead they went through my files, created new fatal error, in the addition, when you go to the page it redirected you to ebay store... so that was fun...

Avatar
fishe

10 March 2009 at 8:14am Community Member, 42 Posts

sounds like a super hosting company ;)

glad it's working...

Avatar
Sam

10 March 2009 at 10:39am Administrator, 685 Posts

Another setting that can cause problems is asp_tags = On.

We fixed some issues that conflicted with asp_tags = On, and those fixes will be released in 2.3.1. but until then, you can always just set asp_tags = off.

Avatar
donlab

15 March 2009 at 4:43pm Community Member, 1 Post

Whats the solution? I can't install. My host is Network Solutions everything was uploaded to /htdocs

# Creating 'mysite/_config.php'...
# Creating /data/9/1/117/15/1769341/user/1912972/htdocs/mysite/_config.php
# Creating '.htaccess' file...
# Creating /data/9/1/117/15/1769341/user/1912972/htdocs/.htaccess

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /data/9/1/117/15/1769341/user/1912972/htdocs/sapphire/core/ManifestBuilder.php on line 391

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /data/9/1/117/15/1769341/user/1912972/htdocs/sapphire/core/ManifestBuilder.php on line 391

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /data/9/1/117/15/1769341/user/1912972/htdocs/sapphire/core/ManifestBuilder.php on line 391

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /data/9/1/117/15/1769341/user/1912972/htdocs/sapphire/core/ManifestBuilder.php on line 391

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /data/9/1/117/15/1769341/user/1912972/htdocs/sapphire/core/ManifestBuilder.php on line 391

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /data/9/1/117/15/1769341/user/1912972/htdocs/sapphire/core/ManifestBuilder.php on line 391
# Building database schema...

Parse error: syntax error, unexpected $end in /data/9/1/117/15/1769341/user/1912972/htdocs/mysite/code/Page.php on line 55