Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

 

Updated versioning for Subsites module

Anyone currently using the subsites module should be aware that there has been a recent...

Read post

Anyone currently using the subsites module should be aware that there has been a recent versioning tweak.

If you are using the 3.1 version of the framework, it's advisable to update your dependency on subsites to follow the new 1.0.*-dev branch, which has been created to follow the current stable release tags (1.0.4, 1.0.5, and so on).

For example, in your composer.json file change the required version to correctly pull the 1.0 version.

"require": {
    . . .
    "silverstripe/subsites": "1.0.*-dev",
    . . .
}

Up until now the main development branch was 0.5, which did not match the stable release versions (1.0.x). This doesn't make much sense, so all the versions have been updated to be consistent with one another.

Those wishing to develop on framework 3.2 should use 1.1.*-dev branch of subsites (which is an alias for dev-master).

For those of you using the Common Web Platform (CWP) basic recipe there is no change to the stable release versions the recipe depends on.

About the author
Damian Mooyman

Damian is a developer who has been stuck into SilverStripe for a few years, and a part of the company for a while too. He’ll be around on github under the handle @tractorcow if you need him.

Post your comment

Comments

No one has commented on this page yet.

RSS feed for comments on this page | RSS feed for all comments

Like what you have read?

Sign up for our weekly blog digest sent to your inbox.

Subscribe