Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

SS fatal error when configuring custom field as Translatable

Go to End

4 Posts   2573 Views


4 Posts

19 January 2008 at 6:46am

Edited: 19/01/2008 6:59am

Hi all,

the problems seems to be known already [1,2], but no solution so far..

My configuration: SS 2.2.1, PHP 5.2.5, eAccelerator v0.9.5.2, Apache 2, Mysql 5.0.45

As soon as I add translation-support for my custom-fields by adding the following to my custom (or some existing) class

static $extensions = array(

SS crashes with a fatal error. The error I'm getting is slightly different dependig if I'm on the site or in the admin.
I figured out that SS tries to call one (user site) or several non existent methods in the repective class.
On the user site Children is called.
On the admin site the methods Children, markUnexpanded, markExpanded, AllChildrenIncludingDeleted, numChildren and isMarked are called.

When I remove the $extensions-array, run /db/build and flush the cache SS works again..

Could someone of the core team have a look at this issue? No way of building a multilingual-site with custom attributes right now :-(





4 Posts

21 January 2008 at 10:29pm

There might be no solution to this yet, but could anyone (of the core team or just another developer) at least confirm that the error is reproducable? Do you need more information how to reproduce the error?

Should I open a ticket for this issue? I badly need a solution for this.

Thanks to anyone,



Community Member, 126 Posts

1 May 2008 at 11:48pm

Edited: 01/05/2008 11:49pm

i got the same problem. after adding a field to 'translatable', the admin interface crashes with the error:

FATAL ERROR: Object::__call() Method 'markUnexpanded' not found in class 'ProjectPage'
At line 190 in C:\xampp\htdocs\silverstripe_behf2\sapphire\core\Object.php

still no solution for this?


Community Member, 25 Posts

27 July 2008 at 5:58am

Edited: 27/07/2008 6:00am

Hi, from a noob!

Same problem here, and I'm in urgent need for a solution. Tried to enable a custom field for translation and got the same fatal error as described above.

static $extensions = array(

The table was created, but as said before the admin crashes!

Documentation says " have to explicitly enable them for translation". Yes, but how then, what do I need to do more? Or, what is wrong?

If there is no solution I guess I will have to rebuild my database from scratch and then enable i18n to get it working. Nothing I really would like to do but...

Is that a correct interpretation of the documentation?