Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Cannot install, issues with mod_rewrite

Go to End

13 Posts   51914 Views


Community Member, 33 Posts

28 April 2007 at 2:48am

Sorry for late reply I didn't see this post. :/
Anyway this happens to stable 2.0.1 too.

I tryed to install (fresh install, not upgrade) the stable 2.0.1 and the same thing happens. I get mod_rewrite problem. The database creation is ok, just url rewriting stop working (well it, never started actually) so it makes whole site unusable. I overcome this problem ( ;], tnx) with applaying old .htaccess in new installation. With editing last line so it points to new insallation of course. That saves the problem.

Here is my httpd.conf:
#Mapping to my local dir...
Alias /test /home/trato/Desktop/Documents/myProgramming/PHP/test_PHP_www
<Directory /home/trato/Desktop/Documents/myProgramming/PHP/test_PHP_www>
#Options Indexes FollowSymLinks
Options All
AllowOverride All
Order allow,deny
Allow from all

I'm using this on Xampp1.6 with specs:
-PHP 5.2.1
-Apache 2.2.4
-mySQL 5.0.37

If you need some config files to check out I can provide them for download if u like.


2 Posts

28 September 2007 at 6:38pm

Hey guys,

My first post here and my first time with SilverStripe. So far, I can't get the thing installed. This is not good.... i'm stuck on the mod_rewrite and I know its something to do with .htaccess or something but i've tried the code so far here and nothing works.

I'm on the first page that says I can connect to my database just fine but it says I dont have the mod:

* mod_rewrite is enabled in your httpd.conf
* AllowOverride is enabled for the current path.

Please help me.


Community Member, 4 Posts

25 February 2008 at 6:06pm

Edited: 25/02/2008 6:16pm

Just found this framework/cms and was intent on installing it on a local testbed to see what it could do. As a website designer and consultant, I looked forward to adding this as one of my design tools, but find myself in the same boat as the other ones in this thread. To give a bit more background on my testbed, I'll illustrate the server platform as follows:

Windows Vista - All updates installed
Using Firefox to run the installer as IE botches everything

Httpd platform:
Apache 2-2-8
PHP 5-2-5
MySQL 5-0-51a

Running the framework from an alias directory configured as follows:
Alias /silverstripe2-2-1 "D:/Design Practice/frameworks/silverstripe2-2-1"
<Directory "D:/Design Practice/frameworks/silverstripe2-2-1">
Options All
AllowOverride All
Order allow,deny
Allow from all

LoadModule rewrite_module modules/ is clearly enabled in the httpd.conf and shows in info.php. I can run the installer to the same point where it stalls at the screen testing for rewrite, then all things hang there.

I have already right clicked all folders in the directories associated with silverstrip and unticked the read only attributes, applying to all files and folders as well. This has not fixed the problem. I did this for the .htaccess file, and the mysite, turtorials, and assets folders as well. Of note, during the install, I also unticked the default theme, BlackCandy so that I could use the tutorial.

Of further note, I also noticed that Silverstrip wants to configure things for localhost and, but with windows vista issues and IE 7+, it required me to configure my apache server for localhost on port 80 only else IE wanted to bomb in Vista with the new security issues. This might be another reason why the mod rewrite testing is not working correctly as localhost is the configuration in the server, and NOT, but I'm not an expert by any means when it comes to servers nor PHP, so it's just something I'm pointing out for you to evaluate and think about. I found it really was quite a PITA to get a local test bed running on a windblows box and am seriously thinking about jumping ship to a more open OS in future.

I suspect it's probably a problem with vista home premium and their new way of handling security issues with files and users, requiring administrative clearance for things and not giving automatic administrative rights without making you jump through hoops when you run a program, having to instead right click the program and select running it as administrator to boot.

As such, the only was I see to get around this is to have some documentation put together to allow users to manually make some of the changes the installer makes to the files in the vista os's.

I'd really like to get this up and running to see what it can do. I also noticed that some people were having issue getting this to work on GoDaddy servers as well, which is who I host with. So in the end, this might not even be a solution for my own site, but it would be a nice tool for the toolbox. Hope that some of my information helps you guys find where the issues are and helps you fix them.


If I click continue regardless, it heads to an error page:
Bad Request

Your browser sent a request that this server could not understand.

Install dead, cannot get any further. Any further attempts to browse to the pages leads to the same error on a varying page, Bad Request. Another curious note I forgot to mention, the installer doesn't even recognize that Apache is installed, can't identify the server.


Community Member, 12 Posts

27 February 2008 at 3:36am


my installation also stopped with the mod_rewrite enabled? question.

The problem was in the .htaccess file, more notably with the rewrite rule at the end.

Your server config is quite different from mine, so this is not much more than a hint to take a look at your .htaccess file and the rewrite rules.
Since I installed in a sub directory it helped to put it before "sapphire/main.php" on the line with the RewriteRule.

Good luck!


Community Member, 4 Posts

27 February 2008 at 11:22am

And the result:

Move 2-2-1 to the htdocs root, try again

Install completes to flush, then after flush, the error as reported, which seems to potentially previously be a cache issue in cache.php line 4 is now in cache.php line 3, which I posted about at

Still no success, and there is no information apparently available that I can find in the forums to fix this issue.

An aside note:
I REALLY wish you guys had a more robust forum and search function. The present functionality really does prohibit easy finding of answers and information one might need when trying to deal with using and fixing silverstripe issues. As such, I can see adoption of a potentially fine framework/cms being prohibitive because of the high learning curve and difficulties one faces in trying to even get this framework installed. I recognize that this is a budding and infant community which still needs time to grow, but I'd suggest that you find ways to overcome these pitfalls or potentially risk killing your infant in the early growing stages. Just a suggestion.

Go to Top