Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

PHPSUEXEC and local php.ini

Go to End

5 Posts   2067 Views


Community Member, 3 Posts

30 March 2007 at 8:06am

Edited: 30/03/2007 8:06am

First off, SilverStrip is incredible. I played with it for a couple of weeks at home and am going to switch my freelance/portfolio site to it.

I using Fused Networks as my host and they meet all of the requirements. But one is kinda funky.

They use PHPSUEXEC. Even though mod_rewrite and AllowOverride are enabled in the https.conf file, apparently I have to put any modifications in a local php.ini file.

My install is failing on the mod_rewrite test saying:

mod_rewrite doesn't appear to be working. Make sure:

* mod_rewite is enabled in your httpd.conf
* AllowOverride is enabled for the current path.

Please check these options, then refresh this page.

I am still researching but does anyone know how I would enable these in a local php.ini, or if SilverStripe will work in this configuration.




Community Member, 3 Posts

30 March 2007 at 8:48am

Solved my own problem. The CMS actually wrote the necessary .htaccess values to a file called .htaccess_rewrite.

I just copied those values into .htaccess, saved it and SilverStripe fired right up.

Once I get my hands dirty I will see if it barks at anything else around phpsuexec.



Forum Moderator, 628 Posts

30 March 2007 at 9:14pm

Edited: 30/03/2007 9:14pm

can you clarify whether your issues above were with 2.0.0 or 2.0.1rc2? the reason i ask is so we know if we need to fix anything, or if we can just go ahead and release 201!

cheers for your positive feedback btw! :)


Community Member, 3 Posts

31 March 2007 at 3:17am

I was installing 2.01rc2. Platform info at the host follows:

Operating system Linux
Kernel version 2.6.9-42.0.8.ELsmp
Machine Type i686
Apache version 1.3.37 (Unix)
PERL version 5.8.7
PHP version 5.2.0
MySQL version 4.1.21-standard-log

If I run into any snags while getting the site in order, I'll post the findings.



Forum Moderator, 628 Posts

31 March 2007 at 5:30am

i think we're okay as this was discussed on IRC and fixed on wednesday, should be in the daily build; its the check that is buggy, not you :P