Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Forum Module /

Discuss the Forum Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba


Go to End

3 Posts   1694 Views


Community Member, 2 Posts

20 September 2012 at 4:56am

I've noticed that this was brought up at least once before, but what are the chances of getting a little bit more documentation for the forums module? I'm really new to using Silverstripe, and so far I haven't had too much trouble with getting the basics down, but I seem to be having some major issues with getting the forums to work.

I was able to get them installed (they show up on the Pages list, and the /dev/build/ bit worked as well for building the new database tables), but when I go to my pages module, all I can do is set up the main forum module itself, as well as setting up some categories. When I go to my actual website however, I don't see anything in regards to posting a new topic, nor do I see a "registration" or "login" link. How would I go about adding these to the website? I'm currently running the latest stable versions of Silverstripe and the forums module (as of the time of this writing, that would be v3.0.2 and v1.0-beta1, respectively), and haven't added anything else to the CMS, minus the blog module (v0.6.0).

I feel that it's also worth mentioning that I'm having the same issue with the blog module, as I seem to have no means of actually posting (or viewing) any blogs. A default blog post was set up, but when I click on the "Blog" button in the main navigation, it simply takes me to the blog page (with the description that I was able to edit), but does not show any blogs at all. Mind you, I made sure that the sample blog post was published and made visible to anyone.


Forum Moderator, 5523 Posts

22 September 2012 at 5:15pm

. When I go to my actual website however, I don't see anything in regards to posting a new topic, nor do I see a "registration" or "login" link.

Do you see anything related to the forum (i.e you should see a search form for forms, all the categories and available forums) if you don't see that on your forums page then the templates have not be found. Make sure you're viewing the latest changes to the page by adding ?flush=1 to the URL.


Community Member, 2 Posts

25 September 2012 at 9:07am

Yup, that definitely worked! I remember reading something about the "?flush=1" step somewhere in the official documentation some time back when I first started researching the Silverstripe CMS, I guess it just slipped my mind. Forums and blogs work perfectly fine now, thank you so much! Silverstripe is definitely an awesome CMS. I've already gone through a couple tutorials on how to extend the CMS a bit (creating an articles section and staff directory), and have even made my own tweaks to those as well. Good stuff!