Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Upload and image handling problems


Go to End


950 Views

Avatar
Tonytr

Community Member, 1 Post

21 February 2010 at 10:51am

This is my second attempt to use Silverstripe as serious competition to three CMSs I usually use. I have got most things to work, but ......

1. In tutorial 2 the staff pages fail when trying to upload the images. I can get them to work locally, but as soon as they are deployed I get 'Action 'admin' isn't allowed on class AssetAdmin' error when a new record is added. The Assets directory has full write permissions. Any idea why?

2. To look at this further I worked locally. I tried a straightforward upload and got 'Action 'admin' isn't allowed on class AssetAdmin' again. Flushing the system several times and removing existing images from the assets/Uploads folder eventually worked.

I then uploaded autumn.jpg to

assets/Uploads/autumn.jpg

Inserting the image to a page resulted in the image being given a path of

admin/assets/Uploads/autumn.jpg

no matter which user with admin rights tries to upload and insert.

Any solutions to either or both of these?

3. Is there a Silverstripe-friendly and stable method of getting a msqldump? I haven't tried the module yet, but I am fed up with manually adding uppercase characters in text files.