Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Modules are using an old cached version of my theme. Tried flushing, no luck!

Go to End

2 Posts   835 Views


Community Member, 9 Posts

9 August 2010 at 5:21am

Edited: 09/08/2010 5:22am

Hey guys,

Have run into a bit of a perculiar problem.

Just finished making some changes to an existing theme I created a few weeks ago. Replaced all the xhtml, css, images, etc. Created an additional page type. Nothing too complicated.

All pages that don't have a third party module attached to them appear correctly. The pages that do have a third party module attached to them, such as ImageGallery, UserForms still use the old stylesheet, breaking the new design.

Looking through the source code, it seems as if the old page template has been cached somewhere. I have tried rebuilding the site using dev and flush, with no luck.

Really don't want to rebuild everything from scratch.

Any helps much much apprecaited.
- Marcin


Forum Moderator, 1899 Posts

9 August 2010 at 6:12am

Have you tried creating a "silverstripe-cache" folder (which will automatically be used to store temp files) in your site root? That might help - then you can always delete the contents if needed.