Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Any experience running SilverStripe over IPv6?


Go to End


4 Posts   1171 Views

Avatar
grbell

Community Member, 2 Posts

4 February 2011 at 5:37am

Is anyone successfully running SilverStripe in an IPv6 environment, either single or dual-stack? I'd be grateful for a pointer to documentation, or just a quick response to the effect that v6 is known to be possible, known to be broken, on the roadmap for a future version... etc.

Many thanks.

- Greg

Avatar
Willr

Forum Moderator, 5523 Posts

4 February 2011 at 2:46pm

Not sure how much IP specific code is part of SilverStripe (maybe some security fields). I think SS would generally sit on a stack much higher than IP level networking so I would be surprised if it didn't work on a working PHP environment (v6 or 4)

Avatar
grbell

Community Member, 2 Posts

4 February 2011 at 2:54pm

That's certainly my hope - thanks.

Avatar
ttyl

Community Member, 114 Posts

8 February 2011 at 8:42am

I use a lot of IP filtering in my security settings for admin users myself, so if that didn't work it would affect me. however, I'm not knowledgeable enough to answer the question.