Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

installing SS on Amazon Web Service (AWS) instance error

Go to End

2 Posts   2472 Views


Community Member, 6 Posts

7 March 2011 at 1:55am

Hi, I've successfully installed and ran a linux micro instance on AWS Elastic Cloud Compute platform. I'm trying to install Silverstripe 2.4.5. on it and i've encountered these 3 errors:

GD2 support - GD support for PHP not included.
DOM/XML support - DOM/XML support not included in PHP.
date.timezone set and valid - date.timezone option in php.ini must be set in PHP 5.3.0+

I ran a phpinfo command on the server to verify its PHP settings and below is what i found.

#setting for GD:
GD Support - enabled
GD Version - bundled (2.0.34 compatible)

#setting for DOM:
DOM/XML - enabled
DOM/XML - API Version 20031129

#setting for date.timezone:
Directive Local Value Master Value
date.timezone Asia/Singapore Asia/Singapore

As you can see, the PHP settings have already met the requirements but SS says otherwise. The PHP version on the linux server i've installed is PHP Version 5.2.9. Where do you think is the problem here? The AWS linux instance or SS? Do you think updating the PHP version will fix it? Please help. ('~')


Community Member, 6 Posts

8 March 2011 at 10:24pm

Case closed.

For other people who might encounter the same weird SS installation problem on the AWS linux platform (Basic 32-bit Amazon Linux AMI 2010.11.1 Beta), this might be of help. This is actually more of a PHP and server configuration issue, but since I'm using Silverstripe as the first application to run on it, I'll just post my comment here and as a reply to my previous post.

phpinfo does show that GD and DOM/XML are enabled and also shows that date.timezone has been set. However when i checked date.timezone at php.ini, its value was blank. when i ran a GD function, it returned an invalid function error and the same with DOM/XML. So:

GD support fix:
# yum install php-gd

DOM/XML support fix:
# yum install php-xml

date.timezone fix:
edit php.ini

I'm glad that I can finally get my hands dirty on the SS site, but the phpinfo incorrect (as far as I know) data is still worrying me. anyways, I don't want to look back at this time. Moving forward for now...